Konfigurasi VoIP dengan DHCP dan CME (Cisco Call Manager Express) Terpisah

Special thanks to Mohammad Khaled Saeed, my teacher and brother in Palestine.

Menurut Wikipedia, IP Phone merupakan alat komunikasi suara berbasis IP (internet protokol). Menurut Wikipedia juga Voice over Internet Protocol (juga disebut VoIP, IP Telephony, Internet telephony atau Digital Phone) adalah teknologi yang memungkinkan percakapan suara jarak jauh melalui mediainternet. Data suara diubah menjadi kode digital dan dialirkan melalui jaringan yang mengirimkan paket-paket data, dan bukan lewat sirkuit analog telepon biasa.

Berikut cara konfigurasi VoIP dengan DHCP dan CME terpisah serta terhubung dengan switch pada Cisco.

Konfigurasi Router CME

CME_VOICE#sh running-config
Building configuration…

Current configuration : 2520 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname CME_VOICE
!
spanning-tree mode pvst
!

interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0.50
encapsulation dot1Q 50 native
ip address 172.16.2.1 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.1.2
!
!
telephony-service
max-ephones 10
max-dn 20
ip source-address 172.16.3.1 port 2000
!
ephone-dn 1
number 2001
!
ephone-dn 2
number 2002
!
ephone-dn 3
number 2003
!
ephone-dn 4
number 2004
!
ephone 1
device-security-mode none
mac-address 00E0.B074.D1BE
type 7960
button 1:1
!
ephone 2
device-security-mode none
mac-address 00E0.A3BD.2472
type 7960
button 1:2
!
ephone 3
device-security-mode none
mac-address 0000.0C98.4012
type 7960
button 1:3
!
ephone 4
device-security-mode none
mac-address 000B.BE10.5395
type 7960
button 1:4
!
line con 0
line vty 0 4
login
!
!
!
end

Konfigurasi Router DHCP

DHCP_ROUTER#sh running-config
Building configuration…

Current configuration : 821 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname DHCP_ROUTER
!
!
!
!
ip dhcp excluded-address 172.16.1.1 172.16.1.10
ip dhcp excluded-address 172.16.2.1 172.16.2.10
!
ip dhcp pool VOICE
network 172.16.1.0 255.255.255.0
default-router 172.16.1.1
option 150 ip 172.16.1.1
ip dhcp pool DATA
network 172.16.2.0 255.255.255.0
default-router 172.16.2.1
dns-server 4.2.2.2
!
!
!
!
!
!
!
no ip domain-lookup
!
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.3.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.3.2
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line vty 0 4
login
!
!
!
end

Konfigurasi SwitchA

SwitchA#sh running-config
Building configuration…

Current configuration : 1320 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SwitchA
!
!
!
ip routing
!
!
!
spanning-tree mode pvst
!
!
interface FastEthernet0/10
switchport access vlan 30
switchport mode access
!
!
!
interface FastEthernet0/20
switchport trunk native vlan 50
switchport trunk encapsulation dot1q
switchport mode trunk
!
!
!
interface FastEthernet0/24
switchport trunk native vlan 50
switchport trunk encapsulation dot1q
switchport mode trunk
!
!
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end

Konfigurasi SwitchB

SwitchB#sh running-config
Building configuration…

Current configuration : 2135 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SwitchB
!
!
!
ip routing
!
!
!
spanning-tree mode pvst
!
!
!
interface FastEthernet0/1
switchport access vlan 50
switchport trunk native vlan 50
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 10
!
interface FastEthernet0/2
switchport access vlan 50
switchport trunk native vlan 50
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 10
!
interface FastEthernet0/3
switchport access vlan 50
switchport trunk native vlan 50
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 10
!
interface FastEthernet0/4
switchport trunk native vlan 50
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 10
!
interface FastEthernet0/5
switchport access vlan 50
switchport mode access
switchport voice vlan 10
!
!
interface FastEthernet0/20
switchport trunk native vlan 50
switchport trunk encapsulation dot1q
switchport mode trunk
!
!
interface FastEthernet0/24
switchport trunk native vlan 50
switchport trunk encapsulation dot1q
switchport mode trunk
!
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 172.16.1.2 255.255.255.0
ip helper-address 172.16.3.1
!
interface Vlan30
ip address 172.16.3.2 255.255.255.0
!
interface Vlan50
ip address 172.16.2.2 255.255.255.0
ip helper-address 172.16.3.1
!
ip classless
!
!
line con 0
line vty 0 4
login
!
!
!
end

Setelah konfigurasi ini tunggu IP Phone mendapatkan IP dan nomor dari DHCP, setting Masing-masing PC ke DHCP Client.

Untuk file .pkt bisa direquest di kolom komentar. Selamat nge-lab.

6 Balasan ke Konfigurasi VoIP dengan DHCP dan CME (Cisco Call Manager Express) Terpisah

  1. Nuxx mengatakan:

    Minta file .pkt nya boleh gan ?

  2. r10 mengatakan:

    pura2 ngerti dah aku :p

    bisanya aku cuma pakai internetnya doang:mrgreen:

    *pantesan aku hern… kok komen berasa kenal sama foto baksos…. ternyata tohir yg komen

  3. egontara mengatakan:

    kalau yang ini di simulasi memang bisa.. tapi kalau di router benerannya ga jalan soalnya harus masukin SIP di ip phonenya

  4. m misbahul munir mengatakan:

    Salam mas,,,, mau tanya, untuk Konfigurasi Router CME dan konfigurasi lainya itu kita actionya di menu apa ya? bagai mana caranya? saya belum paham dan ingin belajar, terima kasih,, mohon bantuannya …please replay

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

Pendekar Tinta

Membangun Peradaban Melalui Tulisan

Iqbal1

Hidup adalah Perjuangan...

rifdanella

combinations of life, blog and technlogy

Sekedar berbagi...

Belajar hingga akhir hayat..! Semakin banyak kita tahu, semakin sadar bahwa kita belum tahu banyak dan kita masih harus terus belajar agar semakin tahu dan semakin mengerti... Dan Jadilah seperti padi, semakin tua semakin berisi tapi dia semakin merunduk... (Nathan Gusti Ryan)

Tempat Nongkrong Anak Fisika Universitas Udayana Bali

Tempat Nongkrong Anak Fisika Universitas Udayana Bali

%d blogger menyukai ini: